Slab - Application response degradation – Incident details

All systems operational

Application response degradation

Resolved
Degraded performance
Started 21 days agoLasted about 3 hours

Affected

Application

Degraded performance from 12:14 PM to 3:17 PM

API

Degraded performance from 12:14 PM to 3:17 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

    We have finished our investigation into this issue. The root cause was a recent change we made which inadvertently caused some draft posts to return an error when loaded. This error resulted in increased memory usage, degrading performance and preventing some posts from loading or saving in a timely manner. In the process of resolving the first issue, we encountered a separate, unrelated caching problem which required additional time to resolve. Both issues were ultimately resolved by restoring a previous version of the application.

    We have been monitoring our error rates and memory usage, and they have remained stable since the incident's resolution.

  • Investigating
    Investigating
    We are currently investigating this incident.