All systems operational

Increased occurrence of "Still trying to save..." message while editing posts

Resolved
Operational
Started 5 months ago Lasted 11 days

Affected

Application
Updates
  • Resolved
    Resolved

    Relevant metrics have remained normal for three full days and we consider the incident resolved.

    The root cause was a recent minor version library upgrade that included performance enhancements, but also an unexpected side effect on how we handled reconnections, particularly when a computer wakes up from sleep. Our team was able to adjust for the upgrade change, so reconnections would again be immediate, resulting in faster post saving like before.

  • Monitoring
    Update

    We have observed the expected subsequent drop in the slow save warning events and will continue monitoring this and related metrics.

  • Monitoring
    Monitoring

    The fix has been deployed and we are currently monitoring the result.

  • Identified
    Update

    The potential fix has been tested on our staging environment, and the fix is now awaiting deployment.

  • Identified
    Update

    A potential fix has been implemented.

  • Identified
    Identified

    A potential root cause has been identified.

  • Investigating
    Investigating

    The post should eventually save and there is no system degradation or increased failure to save. We are investigating why our application client is not attempting to save immediately or sooner when it could and should.