All systems operational

Delay in sending emails

Resolved
Operational
Started over 1 year ago Lasted about 17 hours

Affected

Application
Updates
  • Resolved
    Resolved

    Our partner has resolved the issue, and all emails are being delivered timely. All previously queued emails were delivered as well.

  • Monitoring
    Monitoring

    Our provider's delay is improving and we will continue to monitor the situation.

  • Identified
    Update

    Our provider is continuing to work on resolving the issue. Meanwhile, emails continue to be delivered, with a delay. We will keep posting updates here.

  • Identified
    Identified

    We are experiencing a delay in sending emails due to an issue with our provider. Emails are not lost and will be delivered slowly. We’ll post updates here, and thank you for your patience.